Please help with MText

Aug 15, 2014 at 10:52 PM
Edited Aug 15, 2014 at 11:10 PM
I'm trying to create MText entity with next parameters:
  1. True Type Font ('Arial' for example)
  2. Specific style ('Bold' for example)
  3. WidthFactor: 1.4
CAD version: 2000

I tried to use Formatting Codes but the result is incorrect:
 var thickStyle = new TextStyle("ArialTk", "Arial.ttf")
                           {
                               Height = 3.0,
                               WidthFactor = 1.4
                           };
                           dxf.AddEntity(new MText(@"{\fArial|b1|i0|c0|p34|;Simple MText}", new Vector2(0, 45), 3.0, 100, thickStyle));
result:
Image

new font style parameters:
Image

What is wrong with font style view?
Also i tried to put all font style parameters to formatting code but result is the same.
Coordinator
Aug 16, 2014 at 4:08 PM
I have not been able to reproduce your problem, I tried it with different programs and none of them showed the problem you describe. Every thing seems fine, your code is right, and the information shown in your screenshots are all correct. This indicates that the dxf have been created and read properly, but for unknown reasons AutoCad is not rendering the text correctly. It looks like that the Arial font is not used, and the default simplex.shx font is being used instead.

What worries me is that from the screenshots seems that you are using Windows 8 and you said that you are using AutoCad 2000, and they are not officially compatible. Perhaps there are issues in this regard.

Daniel
Marked as answer by crozium on 8/16/2014 at 1:48 PM
Aug 16, 2014 at 8:21 PM
Edited Aug 16, 2014 at 8:48 PM
Thank You for answer!